libosinfo-0.3.1.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. VALA_USE_DEPEND="vapigen"
  5. inherit gnome2 udev vala
  6. DESCRIPTION="GObject library for managing information about real and virtual OSes"
  7. HOMEPAGE="http://libosinfo.org/"
  8. SRC_URI="http://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.gz"
  9. LICENSE="GPL-2 LGPL-2.1"
  10. SLOT="0"
  11. IUSE="+introspection +vala test"
  12. REQUIRED_USE="vala? ( introspection )"
  13. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
  14. RDEPEND="
  15. >=dev-libs/glib-2.36.0:2
  16. >=dev-libs/libxslt-1.0.0:=
  17. dev-libs/libxml2:=
  18. >=net-libs/libsoup-2.42:2.4
  19. sys-apps/hwids
  20. introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
  21. "
  22. DEPEND="${RDEPEND}
  23. dev-libs/gobject-introspection-common
  24. >=dev-util/gtk-doc-am-1.10
  25. virtual/pkgconfig
  26. test? ( dev-libs/check )
  27. vala? ( $(vala_depend) )
  28. "
  29. src_prepare() {
  30. gnome2_src_prepare
  31. use vala && vala_src_prepare
  32. }
  33. src_configure() {
  34. gnome2_src_configure \
  35. --disable-static \
  36. $(use_enable test tests) \
  37. $(use_enable introspection) \
  38. $(use_enable vala) \
  39. --disable-coverage
  40. }