libosinfo-1.0.0-r1.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. VALA_USE_DEPEND="vapigen"
  5. inherit gnome2 udev vala
  6. DESCRIPTION="GObject library for managing information about real and virtual OSes"
  7. HOMEPAGE="http://libosinfo.org/"
  8. SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.gz"
  9. LICENSE="GPL-2 LGPL-2.1"
  10. SLOT="0"
  11. IUSE="+introspection +vala test"
  12. REQUIRED_USE="vala? ( introspection )"
  13. KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
  14. # Unsure about osinfo-db-tools rdep, but at least fedora does it too
  15. RDEPEND="
  16. >=dev-libs/glib-2.36.0:2
  17. >=net-libs/libsoup-2.42:2.4
  18. >=dev-libs/libxml2-2.6.0
  19. >=dev-libs/libxslt-1.0.0
  20. sys-apps/hwids[pci,usb]
  21. sys-apps/osinfo-db-tools
  22. sys-apps/osinfo-db
  23. introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
  24. "
  25. # perl dep is for pod2man
  26. DEPEND="${RDEPEND}
  27. dev-lang/perl
  28. dev-libs/gobject-introspection-common
  29. >=dev-util/gtk-doc-am-1.10
  30. >=dev-util/intltool-0.40.0
  31. virtual/pkgconfig
  32. test? ( dev-libs/check )
  33. vala? ( $(vala_depend) )
  34. "
  35. src_prepare() {
  36. gnome2_src_prepare
  37. use vala && vala_src_prepare
  38. }
  39. src_configure() {
  40. gnome2_src_configure \
  41. --with-usb-ids-path=/usr/share/misc/usb.ids \
  42. --with-pci-ids-path=/usr/share/misc/pci.ids \
  43. --disable-static \
  44. $(use_enable test tests) \
  45. $(use_enable introspection) \
  46. $(use_enable vala) \
  47. --disable-coverage
  48. }