libservicelog-1.0.1.ebuild 613 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils autotools
  4. DESCRIPTION="Provides a library for logging service-related events"
  5. SRC_URI="mirror://sourceforge/linux-diag/${P}.tar.gz"
  6. HOMEPAGE="http://linux-diag.sourceforge.net/servicelog/"
  7. SLOT="0"
  8. LICENSE="IBM"
  9. KEYWORDS="ppc ppc64"
  10. IUSE=""
  11. DEPEND="dev-db/sqlite"
  12. RDEPEND="${DEPEND}
  13. virtual/logger"
  14. src_unpack() {
  15. unpack ${A}
  16. cd "${S}"
  17. epatch "${FILESDIR}"/libservicelog-1.0.1.patch
  18. eautoreconf
  19. }
  20. src_install () {
  21. emake install DESTDIR="${D}" || die
  22. dodoc ChangeLog || die
  23. }