libuuid-1.0.3.ebuild 513 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit libtool
  5. DESCRIPTION="Portable uuid C library"
  6. HOMEPAGE="http://libuuid.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~x64-solaris ~x86-solaris"
  11. IUSE=""
  12. DEPEND=""
  13. RDEPEND="${DEPEND}"
  14. src_prepare() {
  15. eapply_user
  16. elibtoolize
  17. }
  18. src_configure() {
  19. econf --disable-static
  20. }
  21. src_install() {
  22. default
  23. rm "${ED}"/usr/lib/*.la || die
  24. }