libvpd-2.2.5.ebuild 820 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils udev
  5. DESCRIPTION="Library implementation for listing vpds"
  6. HOMEPAGE="https://sourceforge.net/projects/linux-diag/"
  7. SRC_URI="https://sourceforge.net/projects/linux-diag/files/libvpd/${PV}/libvpd-${PV}.tar.gz"
  8. LICENSE="IBM"
  9. SLOT="0"
  10. KEYWORDS="~ppc ~ppc64"
  11. IUSE="static-libs"
  12. DEPEND="
  13. >=dev-db/sqlite-3.7.8
  14. sys-libs/zlib
  15. "
  16. RDEPEND="${DEPEND}"
  17. src_configure() {
  18. # sysconfdir is used only to establish where the udev rules file should go
  19. # unfortunately it also adds the subdirs on its own so we strip it down to
  20. # dirname
  21. econf \
  22. $(use_enable static-libs static) \
  23. --sysconfdir="$( dirname $(get_udevdir) )"
  24. }
  25. src_install(){
  26. emake DESTDIR="${D}" install
  27. prune_libtool_files
  28. }