nss-usrfiles-2.18.1.ebuild 678 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. MY_PN="nss-altfiles"
  5. MY_P="${MY_PN}-${PV}"
  6. DESCRIPTION="NSS module to read passwd/group files from CoreOS /usr location"
  7. HOMEPAGE="https://github.com/coreos/${MY_PN}"
  8. SRC_URI="https://github.com/coreos/${MY_PN}/archive/v${PV}.zip -> ${MY_P}.zip"
  9. LICENSE="LGPL-2.1+"
  10. SLOT="0"
  11. KEYWORDS="~amd64-linux"
  12. IUSE=""
  13. DEPEND=""
  14. RDEPEND="${DEPEND}"
  15. S="${WORKDIR}/${MY_P}"
  16. src_configure() {
  17. : # Don't bother with the custom configure script.
  18. }
  19. src_compile() {
  20. emake DATADIR=/usr/share/baselayout MODULE_NAME=usrfiles
  21. }
  22. src_install() {
  23. dolib.so libnss_usrfiles.so.2
  24. }