system-config-base-1-r1.ebuild 869 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2008 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils pam
  4. DESCRIPTION="system-config-* layout package"
  5. SRC_URI=""
  6. HOMEPAGE="https://www.gentoo.org/"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~ppc ~x86"
  10. IUSE=""
  11. RDEPEND="virtual/pam"
  12. S=${WORKDIR}
  13. src_unpack() {
  14. cp "${FILESDIR}"/config-util . || die "failed to copy config-util"
  15. epatch "${FILESDIR}"/${PVR}-pam-0.99.8.0-r2-compat.patch
  16. }
  17. src_install() {
  18. dopamd config-util
  19. }
  20. pkg_postinst() {
  21. if [ "$(stat -c%a ${ROOT}etc/default/useradd)" != "644" ] ; then
  22. echo
  23. ewarn
  24. ewarn "Your ${ROOT}etc/default/useradd file must be world-readable"
  25. ewarn "for the system-config-* utilities to work properly."
  26. ewarn "If you did not change them on purpose, consider running:"
  27. ewarn
  28. ewarn " chmod 0644 ${ROOT}etc/default/useradd"
  29. echo
  30. fi
  31. }