tapi-1.30.ebuild 962 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils flag-o-matic
  5. DESCRIPTION="Text-based Application Programming Interface"
  6. HOMEPAGE="https://opensource.apple.com/source/tapi"
  7. SRC_URI="https://opensource.apple.com/tarballs/${PN}/${P}.tar.gz"
  8. S="${WORKDIR}/lib${P}"
  9. LICENSE="|| ( UoI-NCSA MIT )"
  10. SLOT="0"
  11. KEYWORDS="~x64-macos ~x86-macos"
  12. DOCS=( Readme.md )
  13. PATCHES=(
  14. "${FILESDIR}"/${PN}-1.30-llvm-out-of-tree.patch
  15. "${FILESDIR}"/${PN}-1.30-llvm-new-error-api.patch
  16. "${FILESDIR}"/${PN}-1.30-llvm-config.patch
  17. "${FILESDIR}"/${PN}-1.30-allow-all-clients.patch
  18. )
  19. src_configure() {
  20. local mycmakeargs=(
  21. -DCMAKE_MODULE_PATH="${EPREFIX}/usr/lib/cmake/llvm;${EPREFIX}/usr/share/llvm/cmake"
  22. )
  23. # poor man's configure
  24. [ -f "${EPREFIX}"/usr/include/llvm/Support/Error.h ] && \
  25. append-cxxflags -DLLVM_NEW_ERROR_API=1
  26. append-cxxflags -std=c++11
  27. cmake-utils_src_configure
  28. }