tdb-1.3.11.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE="threads"
  6. inherit waf-utils multilib-minimal python-single-r1
  7. DESCRIPTION="A simple database API"
  8. HOMEPAGE="http://tdb.samba.org/"
  9. SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
  13. IUSE="python"
  14. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  15. RDEPEND="python? ( ${PYTHON_DEPS} )"
  16. DEPEND="
  17. ${RDEPEND}
  18. ${PYTHON_DEPS}
  19. app-text/docbook-xml-dtd:4.2"
  20. WAF_BINARY="${S}/buildtools/bin/waf"
  21. src_prepare() {
  22. default
  23. python_fix_shebang .
  24. multilib_copy_sources
  25. }
  26. multilib_src_configure() {
  27. local extra_opts=()
  28. if ! multilib_is_native_abi || ! use python; then
  29. extra_opts+=( --disable-python )
  30. fi
  31. waf-utils_src_configure \
  32. "${extra_opts[@]}"
  33. }
  34. multilib_src_compile() {
  35. # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
  36. unset MAKEOPTS
  37. waf-utils_src_compile
  38. }
  39. multilib_src_test() {
  40. # the default src_test runs 'make test' and 'make check', letting
  41. # the tests fail occasionally (reason: unknown)
  42. emake check
  43. }
  44. multilib_src_install() {
  45. waf-utils_src_install
  46. }