ruby-minitest-1.ebuild 853 B

123456789101112131415161718
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. USE_RUBY="ruby19 ruby20 ruby21 ruby22 jruby"
  5. inherit ruby-ng
  6. DESCRIPTION="Virtual ebuild for the Ruby minitest library"
  7. SLOT="0"
  8. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
  9. RDEPEND="ruby_targets_ruby19? ( || ( dev-ruby/minitest[ruby_targets_ruby19] dev-lang/ruby:1.9 ) )
  10. ruby_targets_ruby20? ( || ( dev-ruby/minitest[ruby_targets_ruby20] dev-lang/ruby:2.0 ) )
  11. ruby_targets_ruby21? ( || ( dev-ruby/minitest[ruby_targets_ruby21] dev-lang/ruby:2.1 ) )
  12. ruby_targets_ruby22? ( || ( dev-ruby/minitest[ruby_targets_ruby22] dev-lang/ruby:2.2 ) )
  13. ruby_targets_jruby? ( dev-ruby/minitest[ruby_targets_jruby] )"