blohg-tumblelog-9999.ebuild 792 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="A blohg extension with reStructuredText directives to run a tumblelog"
  7. HOMEPAGE="https://github.com/rafaelmartins/blohg-tumblelog"
  8. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  9. KEYWORDS="~amd64 ~x86"
  10. if [[ ${PV} = *9999* ]]; then
  11. SRC_URI=
  12. KEYWORDS=
  13. EGIT_REPO_URI="git://github.com/rafaelmartins/blohg-tumblelog.git
  14. https://github.com/rafaelmartins/blohg-tumblelog.git"
  15. inherit git-r3
  16. fi
  17. LICENSE="GPL-2"
  18. SLOT="0"
  19. IUSE=""
  20. DEPEND="
  21. >=www-apps/blohg-0.12
  22. dev-python/pygments[${PYTHON_USEDEP}]
  23. dev-python/pyoembed[${PYTHON_USEDEP}]
  24. dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
  25. RDEPEND="${DEPEND}"