curator-3.0_p20110120-r2.ebuild 694 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1
  6. DESCRIPTION="Gallery generator"
  7. HOMEPAGE="http://furius.ca/curator/"
  8. SRC_URI="mirror://gentoo/curator-3.0_pf078f1686a78.tar.xz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ~hppa ~mips ppc x86"
  12. IUSE=""
  13. DEPEND=""
  14. RDEPEND="${DEPEND}
  15. ${PYTHON_DEPS}
  16. dev-python/pillow[${PYTHON_USEDEP}]
  17. virtual/imagemagick-tools"
  18. REQUIRED_USE=${PYTHON_REQUIRED_USE}
  19. S="${WORKDIR}/curator-3.0_pf078f1686a78"
  20. src_compile() {
  21. python_fix_shebang hs/curator-hs
  22. }
  23. src_install() {
  24. dobin hs/curator-hs
  25. insinto /usr/share/curator
  26. doins -r hs
  27. }