gnopaste-0.5.5.ebuild 745 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit webapp eutils
  5. DESCRIPTION="gnopaste is a nopaste script based on PHP with MySQL"
  6. HOMEPAGE="http://gnopaste.sf.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
  8. LICENSE="GPL-2"
  9. KEYWORDS="~x86 ~amd64"
  10. IUSE=""
  11. RDEPEND="virtual/httpd-php
  12. dev-lang/php[mysql]"
  13. need_httpd_cgi
  14. src_prepare() {
  15. esvn_clean
  16. }
  17. src_install() {
  18. webapp_src_preinst
  19. insinto "${MY_HTDOCSDIR}"
  20. doins -r .
  21. webapp_configfile "${MY_HTDOCSDIR}"/config.php
  22. webapp_serverowned "${MY_HTDOCSDIR}"/config.php
  23. webapp_serverowned "${MY_HTDOCSDIR}"/install.php
  24. webapp_postinst_txt en "${FILESDIR}"/postinstall-en-${PV}.txt
  25. webapp_src_install
  26. }