icingaweb2-module-graphite-9999.ebuild 756 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Icinga Web 2 plugin for pnp4nagios"
  5. HOMEPAGE="http://www.icinga.org/"
  6. if [[ "${PV}" == 9999 ]]; then
  7. inherit git-r3
  8. EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-graphite.git"
  9. else
  10. KEYWORDS="~amd64 ~x86"
  11. MY_PN="icingaweb2-module-pnp"
  12. SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
  13. S="${WORKDIR}/${MY_PN}-${PV}"
  14. fi
  15. LICENSE="GPL-2"
  16. SLOT="0"
  17. DEPEND=">=net-analyzer/icinga2-2.1.1
  18. >=www-apps/icingaweb2-2.0.0"
  19. RDEPEND="${DEPEND}"
  20. PATCHES=( "${FILESDIR}/patch-unquote-service.patch" )
  21. src_install() {
  22. insinto "/usr/share/icingaweb2/modules/graphite/"
  23. doins -r "${S}"/*
  24. }