openwebstats-1.1.ebuild 882 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit webapp
  4. DESCRIPTION="PHP stats application that reads Apache log files and imports the data to a MySQL database"
  5. HOMEPAGE="http://openwebstats.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. KEYWORDS="~x86"
  9. IUSE=""
  10. DEPEND="dev-lang/php"
  11. S=${WORKDIR}/${PN}
  12. src_install() {
  13. webapp_src_preinst
  14. dodoc README
  15. ## Main application
  16. cp -r . "${D}${MY_HTDOCSDIR}"
  17. cp "${FILESDIR}/config.php" "${D}${MY_HTDOCSDIR}/"
  18. ## Docs installed, remove unnecessary files
  19. rm -f "${D}${MY_HTDOCSDIR}/README"
  20. rm -f "${D}${MY_HTDOCSDIR}/CHANGELOG"
  21. # Database creation
  22. webapp_sqlscript mysql "${D}${MY_HTDOCSDIR}/openwebstats.sql"
  23. # Postinstall instructions
  24. webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
  25. webapp_src_install
  26. }