intel-gpu-tools-1.15.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit xorg-2
  5. DESCRIPTION="Intel GPU userland tools"
  6. KEYWORDS="amd64 x86"
  7. IUSE="test-programs unwind video_cards_nouveau"
  8. RESTRICT="test"
  9. DEPEND="dev-libs/glib:2
  10. >=x11-libs/cairo-1.12.0
  11. >=x11-libs/libdrm-2.4.64[video_cards_intel,video_cards_nouveau?]
  12. >=x11-libs/libpciaccess-0.10
  13. unwind? ( sys-libs/libunwind )"
  14. RDEPEND="${DEPEND}"
  15. PATCHES=(
  16. "${FILESDIR}"/${PN}-1.12-inttypes.patch #582430
  17. "${FILESDIR}"/${PN}-1.12-sysmacros.patch #581080
  18. )
  19. src_configure() {
  20. XORG_CONFIGURE_OPTIONS=(
  21. $(use_enable video_cards_nouveau nouveau)
  22. $(use_enable test-programs tests)
  23. $(use_with unwind libunwind)
  24. )
  25. xorg-2_src_configure
  26. }
  27. src_install() {
  28. xorg-2_src_install
  29. if use test-programs; then
  30. local testprogram
  31. pushd "${AUTOTOOLS_BUILD_DIR}"/tests >/dev/null || die
  32. for testprogram in $(<multi-tests.txt) $(<single-tests.txt); do
  33. if [[ -f ${testprogram} ]]; then
  34. dobin "${testprogram}"
  35. fi
  36. done
  37. popd >/dev/null
  38. fi
  39. }
  40. pkg_postinst() {
  41. xorg-2_pkg_postinst
  42. if use test-programs; then
  43. elog "Test programs for DRM driver development were installed. These are not"
  44. elog "designed to run outside their source tree, so may or may not work as"
  45. elog "intended."
  46. fi
  47. }