whyteboard-0.41.1.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit eutils python-single-r1 multilib
  6. DESCRIPTION="A simple image, PDF and postscript file annotator"
  7. HOMEPAGE="http://whyteboard.org/"
  8. SRC_URI="
  9. mirror://sourceforge/${PN}/${P}.tar.gz
  10. https://dev.gentoo.org/~lxnay/${PN}/${PN}.png"
  11. LICENSE="ISC"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE=""
  15. DEPEND="${PYTHON_DEPS}"
  16. RDEPEND="${DEPEND}
  17. dev-python/wxpython:*[${PYTHON_USEDEP}]
  18. media-gfx/imagemagick"
  19. src_install() {
  20. doicon "${DISTDIR}"/${PN}.png
  21. domenu "${FILESDIR}"/${PN}.desktop
  22. dodoc CHANGELOG.txt DEVELOPING.txt README.txt TODO.txt
  23. python_domodule images locale ${PN} ${PN}-help ${PN}.py
  24. cat >> "${T}/${PN}" <<- EOF
  25. #!/bin/sh
  26. exec ${PYTHON} -O "$(python_get_sitedir)/${PN}/${PN}.py"
  27. EOF
  28. dobin "${T}/${PN}"
  29. python_optimize
  30. }
  31. pkg_preinst() {
  32. echo
  33. elog "This application is very experimental and some features"
  34. elog "are not yet implemented, however you can live with it"
  35. echo
  36. }