xsm-1.0.3.ebuild 841 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xorg-2
  5. DESCRIPTION="X Session Manager"
  6. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
  7. IUSE="rsh"
  8. RDEPEND="x11-libs/libXaw
  9. x11-libs/libX11
  10. x11-libs/libXt
  11. x11-libs/libICE
  12. x11-libs/libSM
  13. rsh? ( net-misc/netkit-rsh )"
  14. DEPEND="${RDEPEND}"
  15. pkg_setup() {
  16. # (#158056) /usr/$(get_libdir)/X11/xsm could be a symlink
  17. local XSMPATH="${EROOT}usr/$(get_libdir)/X11/xsm"
  18. if [[ -L ${XSMPATH} ]]; then
  19. einfo "Removing symlink ${XSMPATH}"
  20. rm -f ${XSMPATH} || die "failed to remove symlink ${XSMPATH}"
  21. fi
  22. xorg-2_pkg_setup
  23. }
  24. src_configure() {
  25. XORG_CONFIGURE_OPTIONS="$(use_with rsh rsh /usr/bin/rsh)"
  26. xorg-2_src_configure
  27. }