xf86-video-savage-2.3.9.ebuild 735 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. XORG_DRI=dri
  5. inherit xorg-2
  6. DESCRIPTION="S3 Savage video driver"
  7. KEYWORDS="alpha amd64 ia64 ppc sparc x86 ~amd64-fbsd ~x86-fbsd"
  8. IUSE="dri"
  9. RDEPEND=">=x11-base/xorg-server-1.0.99"
  10. DEPEND="${RDEPEND}
  11. >=x11-proto/xextproto-7.0.99.1"
  12. pkg_setup() {
  13. XORG_CONFIGURE_OPTIONS=(
  14. $(use_enable dri)
  15. )
  16. xorg-2_pkg_setup
  17. }
  18. pkg_postinst() {
  19. if has_version ">=x11-base/xorg-server-1.12.99"; then
  20. elog "Your X server no longer supports XAA, so xf86-video-savage will fall back"
  21. elog "to shadowFB. Enable EXA in your X.org configuration to still have some 2D"
  22. elog "acceleration. See \"man 4 savage\" for details."
  23. fi
  24. }