apwal-0.4.5-r2.ebuild 582 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="A simple application launcher and combined editor"
  6. HOMEPAGE="http://apwal.free.fr/"
  7. SRC_URI="http://apwal.free.fr/download/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86 ~x86-fbsd"
  11. IUSE=""
  12. RDEPEND="x11-libs/gtk+:2
  13. x11-libs/gdk-pixbuf
  14. dev-libs/libxml2
  15. dev-libs/glib:2"
  16. DEPEND="${RDEPEND}
  17. virtual/pkgconfig"
  18. PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
  19. S=${WORKDIR}/${PN}
  20. src_configure() {
  21. tc-export CC
  22. }