devilspie-0.23.ebuild 969 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools toolchain-funcs
  5. DESCRIPTION="A Window Matching utility similar to Sawfish's Matched Windows feature"
  6. HOMEPAGE="http://www.burtonini.com/blog/tag/devilspie.html"
  7. SRC_URI="http://www.burtonini.com/computing/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ppc ~sparc x86 ~amd64-linux ~x86-linux"
  11. IUSE=""
  12. RDEPEND="
  13. >=dev-libs/glib-2.10
  14. x11-libs/gtk+:3[X]
  15. x11-libs/libwnck:3
  16. x11-libs/libX11"
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig
  19. dev-util/intltool
  20. sys-devel/gettext
  21. gnome-base/gnome-common" # Required by eautoreconf
  22. src_prepare() {
  23. default
  24. sed -i -e "s:\(/usr/share/doc/devilspie\):\1-${PVR}:" devilspie.1 || die
  25. sed -i -e '/-DG.*_DISABLE_DEPRECATED/d' src/Makefile.am || die
  26. mv configure.{in,ac} || die
  27. eautoreconf
  28. LIBS="$($(tc-getPKG_CONFIG) --libs x11)"
  29. }
  30. src_install() {
  31. default
  32. keepdir /etc/devilspie
  33. }