icewmcp-3.2-r4.ebuild 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit multilib python-single-r1
  6. MY_PN=IceWMControlPanel
  7. DESCRIPTION="A complete control panel for IceWM using gtk & python"
  8. HOMEPAGE="http://icesoundmanager.sourceforge.net/index.php"
  9. SRC_URI="mirror://sourceforge/icesoundmanager/${MY_PN}-${PV}.tar.bz2"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="amd64 ~ppc x86"
  13. DEPEND="
  14. dev-python/pygtk:2
  15. x11-libs/gtk+:2
  16. x11-wm/icewm
  17. "
  18. RDEPEND="${DEPEND}"
  19. S=${WORKDIR}/INSTALL-IceWMCP
  20. src_prepare() {
  21. rm -rf licenses
  22. mv doc .. || die
  23. }
  24. src_install() {
  25. local dest="/usr/$(get_libdir)/${P}"
  26. insinto ${dest}
  27. doins -r *
  28. local w wraps=(
  29. "IceWMCP.py IceWMCP"
  30. "IceWMCPKeyboard.py IceWMCP-Keyboard"
  31. "IceWMCPMouse.py IceWMCP-Mouse"
  32. "pyspool.py IceWMCP-PySpool"
  33. "IceWMCPWallpaper.py IceWMCP-Wallpaper"
  34. "IceWMCPWinOptions.py IceWMCP-WinOptions"
  35. "phrozenclock.py PhrozenClock"
  36. "icesound.py IceSoundManager"
  37. "IceWMCP_GtkPCCard.py GtkPCCard"
  38. "IceMe.py iceme"
  39. "icepref.py icepref"
  40. "icepref_td.py icepref_td"
  41. "IceWMCPGtkIconSelection.py IceWMCP-Icons"
  42. "IceWMCPEnergyStar.py IceWMCP-EnergyStar"
  43. )
  44. for w in "${wraps[@]}" ; do
  45. set -- ${w}
  46. printf '#!/bin/sh\nexec %s %s/%s\n' "${EPYTHON}" "${dest}" "$1" > "${T}"/$2
  47. dobin "${T}"/$2 || die
  48. done
  49. dodoc ../doc/*.txt
  50. dohtml ../doc/*.html
  51. python_optimize "${D}/${dest}"
  52. }