launchy-2.5-r1.ebuild 952 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit fdo-mime gnome2-utils qmake-utils
  5. DESCRIPTION="utility that merges application menus, your desktop and even your file manager"
  6. HOMEPAGE="http://www.launchy.net/"
  7. SRC_URI="http://www.launchy.net/downloads/src/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND="
  13. dev-qt/qtgui:4
  14. x11-libs/libX11
  15. "
  16. DEPEND="${RDEPEND}
  17. dev-libs/boost
  18. x11-proto/xproto
  19. "
  20. PATCHES=(
  21. "${FILESDIR}"/${P}-underlink.patch
  22. "${FILESDIR}"/${P}-prefix-and-libdir.patch
  23. )
  24. src_configure() {
  25. eqmake4 Launchy.pro PREFIX="${EPREFIX}"/usr LIBDIR="$(get_libdir)"
  26. }
  27. src_install() {
  28. emake INSTALL_ROOT="${D}" install
  29. einstalldocs
  30. }
  31. pkg_preinst() {
  32. gnome2_icon_savelist
  33. }
  34. pkg_postinst() {
  35. fdo-mime_desktop_database_update
  36. gnome2_icon_cache_update
  37. }
  38. pkg_postrm() {
  39. fdo-mime_desktop_database_update
  40. gnome2_icon_cache_update
  41. }