libinput-gestures-2.15.ebuild 759 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python{3_4,3_5} )
  5. inherit python-single-r1
  6. DESCRIPTION="Actions gestures on your touchpad using libinput"
  7. HOMEPAGE="https://github.com/bulletmark/${PN}"
  8. SRC_URI="https://github.com/bulletmark/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="kde gtk"
  13. RDEPEND="${PYTHON_DEPS}
  14. dev-libs/libinput
  15. x11-misc/xdotool
  16. x11-misc/wmctrl"
  17. DEPEND="dev-libs/libinput
  18. dev-util/desktop-file-utils
  19. gtk? ( x11-libs/gtk+:3 )
  20. kde? ( kde-plasma/kde-cli-tools:5 )"
  21. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  22. pkg_postinst() {
  23. elog "You must be in the input group to read the touchpad device."
  24. }