qarma-1.ebuild 547 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit qmake-utils
  5. DESCRIPTION="Zenity Clone for Qt5"
  6. HOMEPAGE="https://github.com/luebking/qarma"
  7. SRC_URI="https://github.com/luebking/qarma/archive/t${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. DEPEND="dev-qt/qtcore:5 dev-qt/qtgui:5 dev-qt/qtwidgets:5 dev-qt/qtx11extras:5"
  13. RDEPEND="${DEPEND}"
  14. S="${WORKDIR}/${PN}-t${PV}"
  15. src_configure() {
  16. eqmake5
  17. }
  18. src_install() {
  19. dobin qarma
  20. }