qtfm-5.5-r1.ebuild 957 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit fdo-mime qmake-utils
  5. DESCRIPTION="A small, lightweight file manager for desktops based on pure Qt"
  6. HOMEPAGE="http://www.qtfm.org/"
  7. SRC_URI="http://www.qtfm.org/${P}.tar.gz?attredirects=0 -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. # file is for LIBS += -lmagic
  13. RDEPEND="sys-apps/file
  14. dev-qt/qtgui:4"
  15. DEPEND="${RDEPEND}"
  16. PATCHES=( "${FILESDIR}"/${P}-gcc6.patch )
  17. src_prepare() {
  18. default
  19. sed -i \
  20. -e "/^docs.path/s:qtfm:${PF}:" \
  21. -e '/^docs.files/s: COPYING::' \
  22. ${PN}.desktop || die
  23. sed -i \
  24. -e '/MimeType=/s|$|;|' \
  25. -e '/Categories=/s|$|;System;FileTools;|' \
  26. ${PN}.desktop || die
  27. }
  28. src_configure() {
  29. eqmake4
  30. }
  31. src_install() {
  32. emake INSTALL_ROOT="${D}" install
  33. einstalldocs
  34. }
  35. pkg_postinst() {
  36. fdo-mime_desktop_database_update
  37. }
  38. pkg_postrm() {
  39. fdo-mime_desktop_database_update
  40. }