qtfm-5.5.ebuild 801 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit fdo-mime qt4-r2
  5. DESCRIPTION="A small, lightweight file manager for desktops based on pure Qt"
  6. HOMEPAGE="http://www.qtfm.org/"
  7. SRC_URI="http://www.qtfm.org/${P}.tar.gz?attredirects=0 -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. # file is for LIBS += -lmagic
  13. RDEPEND="sys-apps/file
  14. dev-qt/qtgui:4"
  15. DEPEND="${RDEPEND}"
  16. src_prepare() {
  17. sed -i \
  18. -e "/^docs.path/s:qtfm:${PF}:" \
  19. -e '/^docs.files/s: COPYING::' \
  20. ${PN}.desktop || die
  21. sed -i \
  22. -e '/MimeType=/s|$|;|' \
  23. -e '/Categories=/s|$|;System;FileTools;|' \
  24. ${PN}.desktop || die
  25. }
  26. pkg_postinst() { fdo-mime_desktop_database_update; }
  27. pkg_postrm() { fdo-mime_desktop_database_update; }