set_opacity-1.0.ebuild 661 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit toolchain-funcs
  5. DESCRIPTION="Tool for set real compositing for windows through window's id, process' pid etc."
  6. HOMEPAGE="https://github.com/XVilka/set_opacity"
  7. SRC_URI="https://github.com/XVilka/set_opacity/archive-tarball/${PV} -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. DEPEND="x11-libs/libXdamage
  13. x11-libs/libXcomposite
  14. x11-libs/libXfixes
  15. x11-libs/libXrender"
  16. RDEPEND=${DEPEND}
  17. S="${WORKDIR}/x11-tools-set_opacity"
  18. src_compile() {
  19. emake CC="$(tc-getCC)"
  20. }
  21. src_install() {
  22. dobin set_opacity
  23. }