set_opacity-9999.ebuild 605 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. EGIT_REPO_URI="https://github.com/XVilka/set_opacity.git"
  5. inherit git-r3 toolchain-funcs
  6. DESCRIPTION="Tool for set real compositing for windows through window's id, process' pid etc."
  7. HOMEPAGE="https://github.com/XVilka/set_opacity"
  8. SRC_URI=""
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. IUSE=""
  12. DEPEND="x11-libs/libXdamage
  13. x11-libs/libXcomposite
  14. x11-libs/libXfixes
  15. x11-libs/libXrender"
  16. RDEPEND=${DEPEND}
  17. KEYWORDS=""
  18. src_compile() {
  19. emake CC="$(tc-getCC)"
  20. }
  21. src_install() {
  22. dobin set_opacity
  23. }