simple-ccsm-0.8.4-r2.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 )
  5. DISTUTILS_IN_SOURCE_BUILD=1
  6. inherit distutils-r1 gnome2-utils
  7. DESCRIPTION="Simplified Compizconfig Settings Manager"
  8. HOMEPAGE="http://www.compiz.org/"
  9. SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
  13. DEPEND="
  14. dev-util/intltool
  15. virtual/pkgconfig"
  16. RDEPEND="
  17. >=dev-python/compizconfig-python-${PV}[${PYTHON_USEDEP}]
  18. >=dev-python/pygtk-2.10:2[${PYTHON_USEDEP}]
  19. >=x11-misc/ccsm-${PV}[${PYTHON_USEDEP}]
  20. "
  21. python_prepare_all() {
  22. # return error if wrong arguments passed to setup.py
  23. sed -i -e 's/raise SystemExit/\0(1)/' setup.py || die 'sed on setup.py failed'
  24. # fix desktop file
  25. sed -i \
  26. -e '/Categories/s/Compiz/X-\0/' \
  27. -e '/Encoding/d' \
  28. "${PN}".desktop.in || die "sed on ${PN}.desktop.in failed"
  29. distutils-r1_python_prepare_all
  30. }
  31. python_configure_all() {
  32. mydistutilsargs=( build --prefix=/usr )
  33. }
  34. pkg_preinst() {
  35. gnome2_icon_savelist
  36. }
  37. pkg_postinst() {
  38. gnome2_icon_cache_update
  39. }
  40. pkg_postrm() {
  41. gnome2_icon_cache_update
  42. }