sux-1.0-r4.ebuild 602 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="\"su\" wrapper which transfers X credentials"
  6. HOMEPAGE="http://fgouget.free.fr/sux/sux-readme.shtml"
  7. SRC_URI="http://fgouget.free.fr/sux/sux"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm ppc sparc x86"
  11. IUSE=""
  12. S="${WORKDIR}"
  13. RDEPEND="x11-apps/xauth"
  14. src_unpack() {
  15. cp "${DISTDIR}"/${A} .
  16. }
  17. src_prepare() {
  18. epatch \
  19. "${FILESDIR}"/${P}-r1.patch \
  20. "${FILESDIR}"/${PN}-X11R6.patch \
  21. "${FILESDIR}"/${P}-dash.patch
  22. }
  23. src_install() {
  24. dobin sux
  25. }