sxhkd-0.5.7.ebuild 621 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs systemd
  5. DESCRIPTION="Simple X hotkey daemon"
  6. HOMEPAGE="https://github.com/baskerville/sxhkd/"
  7. SRC_URI="https://github.com/baskerville/sxhkd/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="BSD-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. RDEPEND="x11-libs/libxcb
  12. x11-libs/xcb-util-keysyms"
  13. DEPEND="${RDEPEND}
  14. x11-libs/xcb-util"
  15. src_compile() {
  16. emake CC="$(tc-getCC)" PREFIX=/usr
  17. }
  18. src_install() {
  19. emake PREFIX=/usr DESTDIR="${D}" install
  20. systemd_dounit contrib/systemd/${PN}.service
  21. }