viewglob-2.0.4-r1.ebuild 726 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=yes
  5. inherit autotools-utils readme.gentoo
  6. DESCRIPTION="Graphical display of directories and globs referenced at the shell prompt"
  7. HOMEPAGE="http://viewglob.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/viewglob/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc ~sparc x86"
  12. IUSE=""
  13. RDEPEND="
  14. dev-libs/glib:2
  15. x11-libs/gtk+:2
  16. || ( app-shells/bash:* app-shells/zsh )"
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig"
  19. PATCHES=(
  20. "${FILESDIR}"/${P}-underlinking.patch
  21. "${FILESDIR}"/${P}-format-security.patch
  22. )
  23. src_install() {
  24. autotools-utils_src_install
  25. readme.gentoo_src_install
  26. }