xearth-1.1-r1.ebuild 871 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. HOMEPAGE="http://hewgill.com/xearth/original/"
  6. DESCRIPTION="Xearth sets the X root window to an image of the Earth"
  7. SRC_URI="ftp://cag.lcs.mit.edu/pub/tuna/${P}.tar.gz
  8. ftp://ftp.cs.colorado.edu/users/tuna/${P}.tar.gz"
  9. SLOT="0"
  10. LICENSE="xearth"
  11. KEYWORDS="alpha amd64 ppc ppc64 x86"
  12. IUSE=""
  13. RDEPEND="
  14. x11-libs/libX11
  15. x11-libs/libXext
  16. x11-libs/libXt
  17. "
  18. DEPEND="${RDEPEND}
  19. x11-misc/imake
  20. app-text/rman
  21. x11-proto/xproto
  22. "
  23. src_prepare() {
  24. epatch "${FILESDIR}"/${P}-include.patch
  25. }
  26. src_configure() {
  27. xmkmf || die
  28. }
  29. src_compile() {
  30. emake CC=$(tc-getCC) \
  31. CCOPTIONS="${CFLAGS}" \
  32. EXTRA_LDOPTIONS="${LDFLAGS}"
  33. }
  34. src_install() {
  35. newman xearth.man xearth.1
  36. dobin xearth
  37. dodoc BUILT-IN GAMMA-TEST HISTORY README
  38. }