xrootconsole-0.6-r1.ebuild 769 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="A utility that displays its input in a text box on your root window"
  6. HOMEPAGE="https://sourceforge.net/projects/xrootconsole/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. RDEPEND="
  12. x11-libs/libX11"
  13. DEPEND="
  14. ${RDEPEND}
  15. x11-proto/xproto"
  16. PATCHES=(
  17. "${FILESDIR}/${P}.noversion.patch"
  18. "${FILESDIR}/${P}.makefile.patch"
  19. "${FILESDIR}/${P}.manpage.patch"
  20. )
  21. DOCS=( TODO NEWS CREDITS )
  22. src_compile() {
  23. tc-export CC
  24. emake
  25. }
  26. src_install() {
  27. dodir /usr/bin
  28. emake \
  29. MANDIR="${D}usr/share/man/man1" \
  30. BINDIR="${D}usr/bin/" \
  31. install
  32. einstalldocs
  33. }