xteddy-2.2.ebuild 713 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="A cuddly teddy bear (or other image) for your X desktop"
  6. HOMEPAGE="http://webstaff.itn.liu.se/~stegu/xteddy/"
  7. SRC_URI="http://webstaff.itn.liu.se/~stegu/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. RDEPEND="media-libs/imlib2[X,png]
  13. x11-libs/libX11
  14. x11-libs/libXext"
  15. DEPEND="${RDEPEND}
  16. virtual/pkgconfig"
  17. DOCS=( AUTHORS README ChangeLog NEWS xteddy.README )
  18. src_prepare() {
  19. epatch "${FILESDIR}"/${P}-linking.patch
  20. # Fix paths in xtoys script wrt bug #404899
  21. sed -i -e "s:/usr/games:/usr/bin:" xtoys || die
  22. eautoreconf
  23. }