faenza-icon-theme-1.3.1.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit gnome2-utils
  5. MY_P=${PN}_${PV}
  6. DESCRIPTION="A scalable icon theme called Faenza"
  7. HOMEPAGE="http://tiheum.deviantart.com/art/Faenza-Icons-173323228"
  8. # Use Ubuntu repo which has a proper faenza-icon-theme tarball
  9. #SRC_URI="https://faenza-icon-theme.googlecode.com/files/${PN}_${PV}.tar.gz"
  10. SRC_URI="https://ppa.launchpad.net/tiheum/equinox/ubuntu/pool/main/${PN:0:1}/${PN}/${MY_P}.tar.gz"
  11. RESTRICT="binchecks strip"
  12. LICENSE="GPL-3"
  13. SLOT="0"
  14. KEYWORDS="amd64 ~arm x86"
  15. IUSE="minimal"
  16. RDEPEND="!minimal? ( x11-themes/adwaita-icon-theme )
  17. x11-themes/hicolor-icon-theme"
  18. S=${WORKDIR}/${PN}-${PV%.*}
  19. src_prepare() {
  20. local res x
  21. for x in Faenza Faenza-Dark; do
  22. for res in 22 24 32 48 64 96; do
  23. cp "${x}"/places/${res}/start-here-gentoo.png \
  24. "${x}"/places/${res}/start-here.png || die
  25. done
  26. cp "${x}"/places/scalable/start-here-gentoo.svg \
  27. "${x}"/places/scalable/start-here.svg || die
  28. done
  29. }
  30. src_install() {
  31. insinto /usr/share/icons
  32. doins -r Faenza{,-Ambiance,-Dark,-Darker,-Darkest,-Radiance}
  33. # TODO: Install to directories where the apps can find them
  34. # insinto ${somewhere}
  35. # doins -r emesene dockmanager rhythmbox
  36. }
  37. pkg_preinst() { gnome2_icon_savelist; }
  38. pkg_postinst() { gnome2_icon_cache_update; }
  39. pkg_postrm() { gnome2_icon_cache_update; }