fluxbox-styles-fluxmod-20050128-r1.ebuild 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. DESCRIPTION="A collection of FluxBox themes from FluxMod"
  5. HOMEPAGE="http://tenr.de/styles/"
  6. SRC_URI="mirror://gentoo/${P}.tar.bz2"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~arm alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
  10. IUSE=""
  11. RDEPEND=""
  12. DEPEND=">=sys-apps/sed-4"
  13. src_prepare() {
  14. # comment out every rootcommand
  15. find . -name '*.cfg' -exec \
  16. sed -i "{}" -e 's-^\(rootcommand\)-!!! \1-i' \;
  17. # weird tarball...
  18. find . -exec chmod a+r '{}' \;
  19. }
  20. src_install() {
  21. insinto /usr/share/fluxbox/fluxmod/styles
  22. doins -r * || die
  23. insinto /usr/share/fluxbox/menu.d/styles
  24. doins "${FILESDIR}"/styles-menu-fluxmod || die
  25. }
  26. pkg_postinst() {
  27. einfo
  28. einfo "These styles are installed into /usr/share/fluxbox/fluxmod/. The"
  29. einfo "best way to use these styles is to ensure that you are running"
  30. einfo "fluxbox 0.9.10-r3 or later, and then to place the following in"
  31. einfo "your menu file:"
  32. einfo
  33. einfo " [submenu] (Styles) {Select a Style}"
  34. einfo " [include] (/usr/share/fluxbox/menu.d/styles/)"
  35. einfo " [end]"
  36. einfo
  37. einfo "If you use fluxbox-generate_menu or the default global fluxbox"
  38. einfo "menu file, this will already be present."
  39. einfo
  40. einfo "Note that some of these styles use the PNG image format. For"
  41. einfo "these to work, fluxbox must be built with USE=\"imlib\" and"
  42. einfo "imlib2 must be built with USE=\"png\"."
  43. einfo
  44. }