gnome-icon-theme-3.12.0.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. inherit gnome2
  6. DESCRIPTION="GNOME default icon theme"
  7. HOMEPAGE="https://www.gnome.org/ https://people.freedesktop.org/~jimmac/icons/#git"
  8. SRC_URI="${SRC_URI}
  9. branding? ( http://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )"
  10. LICENSE="|| ( LGPL-3 CC-BY-SA-3.0 )
  11. branding? ( CC-Sampling-Plus-1.0 )"
  12. SLOT="0"
  13. IUSE="branding"
  14. KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
  15. RDEPEND=">=x11-themes/hicolor-icon-theme-0.10"
  16. DEPEND="${RDEPEND}
  17. >=x11-misc/icon-naming-utils-0.8.7
  18. >=dev-util/intltool-0.40
  19. sys-devel/gettext
  20. virtual/pkgconfig
  21. "
  22. # This ebuild does not install any binaries
  23. RESTRICT="binchecks strip"
  24. src_prepare() {
  25. if use branding; then
  26. for i in 16 22 24 32 48; do
  27. cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
  28. "${S}"/gnome//${i}x${i}/places/start-here.png \
  29. || die "Copying gentoo logos failed"
  30. done
  31. fi
  32. gnome2_src_prepare
  33. }
  34. src_configure() {
  35. gnome2_src_configure \
  36. --enable-icon-mapping \
  37. GTK_UPDATE_ICON_CACHE=$(type -P true)
  38. }