gnustep-silver-theme-2.5.ebuild 636 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit gnustep-2
  5. DESCRIPTION="a GNUstep silver theme"
  6. HOMEPAGE="http://wiki.gnustep.org/index.php/Themes"
  7. SRC_URI="http://download.gna.org/gnustep-nonfsf/silver.theme-${PV}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86"
  11. IUSE=""
  12. DEPEND=""
  13. RDEPEND="${DEPEND}"
  14. S=${WORKDIR}/Silver.theme
  15. src_install() {
  16. egnustep_env
  17. #install themes
  18. insinto ${GNUSTEP_SYSTEM_LIBRARY}/Themes/Silver.theme
  19. doins -r Resources Theme.bundle
  20. }
  21. pkg_postinst() {
  22. elog "Use gnustep-apps/systempreferences to switch theme"
  23. }