gtk-engines-nodoka-0.7.5.ebuild 783 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils
  5. MY_P="gtk-nodoka-engine-${PV}"
  6. DESCRIPTION="GTK+ engine and themes developed by the Fedora Project"
  7. HOMEPAGE="https://fedorahosted.org/nodoka/"
  8. SRC_URI="https://fedorahosted.org/releases/n/o/nodoka/${MY_P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~x86"
  12. IUSE="animation-rtl"
  13. RDEPEND=">=x11-libs/gtk+-2.18.0:2"
  14. DEPEND="${RDEPEND}
  15. virtual/pkgconfig"
  16. S="${WORKDIR}/${MY_P}"
  17. src_prepare() {
  18. epatch "${FILESDIR}/${P}-glib2.32.patch"
  19. }
  20. src_configure() {
  21. econf \
  22. --disable-dependency-tracking \
  23. --enable-animation \
  24. $(use_enable animation-rtl animationtoleft)
  25. }
  26. src_install() {
  27. default
  28. find "${D}" -name "*.la" -delete || die
  29. }