gtk-engines-unico-1.0.3_pre20121212.ebuild 924 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. MY_PN=${PN/gtk-engines-}
  6. MY_P=${MY_PN}-${PV}
  7. DESCRIPTION="The Unico GTK+ 3.x theming engine"
  8. HOMEPAGE="https://launchpad.net/unico"
  9. #SRC_URI="https://launchpad.net/${MY_PN}/${PV%.*}/${PV}/+download/${MY_P}.tar.gz"
  10. SRC_URI="https://dev.gentoo.org/~tetromino/distfiles/${PN}/${MY_P}.tar.bz2"
  11. LICENSE="LGPL-2.1+"
  12. SLOT="0"
  13. KEYWORDS="amd64 ~ppc ~ppc64 x86"
  14. IUSE=""
  15. RDEPEND=">=dev-libs/glib-2.26:2
  16. >=x11-libs/cairo-1.10[glib]
  17. >=x11-libs/gtk+-3.5.2:3"
  18. DEPEND="${RDEPEND}
  19. virtual/pkgconfig"
  20. S=${WORKDIR}/${MY_PN}-1.0.2
  21. src_configure() {
  22. # $(use_enable debug) controls CPPFLAGS -D_DEBUG and -DNDEBUG but they are currently
  23. # unused in the code itself.
  24. econf \
  25. --disable-static \
  26. --disable-debug \
  27. --disable-maintainer-flags
  28. }
  29. src_install() {
  30. default
  31. prune_libtool_files --modules
  32. }