1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI="5"
- GCONF_DEBUG="no"
- GNOME_TARBALL_SUFFIX="bz2"
- inherit eutils gnome2 multilib-minimal
- DESCRIPTION="GTK+2 standard engines and themes"
- HOMEPAGE="http://www.gtk.org/"
- LICENSE="LGPL-2.1"
- SLOT="2"
- KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
- IUSE="accessibility lua"
- RDEPEND=">=x11-libs/gtk+-2.24.23:2[${MULTILIB_USEDEP}]
- lua? ( dev-lang/lua[${MULTILIB_USEDEP}] )
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-gtklibs-20140508
- !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
- )"
- DEPEND="${RDEPEND}
- >=dev-util/intltool-0.31
- >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
- GNOME2_LA_PUNT="yes"
- src_prepare() {
- # Patch from 2.21.x, fixes building with glib-2.32, bug #410455
- epatch "${FILESDIR}/${P}-glib.h.patch"
- gnome2_src_prepare
- }
- multilib_src_configure() {
- ECONF_SOURCE=${S} \
- gnome2_src_configure \
- --enable-animation \
- $(use_enable lua) \
- $(use_with lua system-lua) \
- $(use_enable accessibility hc)
- }
- multilib_src_install() {
- gnome2_src_install
- }
- multilib_src_install_all() {
- local DOCS=( AUTHORS ChangeLog NEWS README )
- einstalldocs
- }
|