gtk-engines-2.20.2-r1.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. GNOME_TARBALL_SUFFIX="bz2"
  6. inherit eutils gnome2 multilib-minimal
  7. DESCRIPTION="GTK+2 standard engines and themes"
  8. HOMEPAGE="http://www.gtk.org/"
  9. LICENSE="LGPL-2.1"
  10. SLOT="2"
  11. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
  12. IUSE="accessibility lua"
  13. RDEPEND=">=x11-libs/gtk+-2.24.23:2[${MULTILIB_USEDEP}]
  14. lua? ( dev-lang/lua[${MULTILIB_USEDEP}] )
  15. abi_x86_32? (
  16. !<=app-emulation/emul-linux-x86-gtklibs-20140508
  17. !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
  18. )"
  19. DEPEND="${RDEPEND}
  20. >=dev-util/intltool-0.31
  21. >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
  22. GNOME2_LA_PUNT="yes"
  23. src_prepare() {
  24. # Patch from 2.21.x, fixes building with glib-2.32, bug #410455
  25. epatch "${FILESDIR}/${P}-glib.h.patch"
  26. gnome2_src_prepare
  27. }
  28. multilib_src_configure() {
  29. ECONF_SOURCE=${S} \
  30. gnome2_src_configure \
  31. --enable-animation \
  32. $(use_enable lua) \
  33. $(use_with lua system-lua) \
  34. $(use_enable accessibility hc)
  35. }
  36. multilib_src_install() {
  37. gnome2_src_install
  38. }
  39. multilib_src_install_all() {
  40. local DOCS=( AUTHORS ChangeLog NEWS README )
  41. einstalldocs
  42. }