gtk-engines-2.20.2-r2.ebuild 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. GNOME2_LA_PUNT="yes"
  6. GNOME_TARBALL_SUFFIX="bz2"
  7. inherit eutils gnome2 multilib-minimal
  8. DESCRIPTION="GTK+2 standard engines and themes"
  9. HOMEPAGE="http://www.gtk.org/"
  10. LICENSE="LGPL-2.1"
  11. SLOT="2"
  12. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
  13. IUSE="accessibility lua"
  14. RDEPEND="
  15. >=x11-libs/gtk+-2.24.23:2[${MULTILIB_USEDEP}]
  16. lua? ( dev-lang/lua:0[${MULTILIB_USEDEP}] )
  17. abi_x86_32? (
  18. !<=app-emulation/emul-linux-x86-gtklibs-20140508
  19. !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
  20. )
  21. "
  22. DEPEND="${RDEPEND}
  23. >=dev-util/intltool-0.31
  24. >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
  25. "
  26. src_prepare() {
  27. # Patch from 2.21.x, fixes building with glib-2.32, bug #410455
  28. epatch "${FILESDIR}/${P}-glib.h.patch"
  29. # Fix java apps look, bug #523074
  30. epatch "${FILESDIR}/${P}-java-look.patch"
  31. # Apply Fedora fixes/improvements
  32. epatch "${FILESDIR}"/${P}-auto-mnemonics.patch
  33. epatch "${FILESDIR}"/${P}-change-bullet.patch
  34. epatch "${FILESDIR}"/${P}-tooltips.patch
  35. epatch "${FILESDIR}"/${P}-window-dragging.patch
  36. gnome2_src_prepare
  37. }
  38. multilib_src_configure() {
  39. ECONF_SOURCE=${S} \
  40. gnome2_src_configure \
  41. --enable-animation \
  42. $(use_enable lua) \
  43. $(use_with lua system-lua) \
  44. $(use_enable accessibility hc)
  45. }
  46. multilib_src_install() {
  47. gnome2_src_install
  48. }
  49. multilib_src_install_all() {
  50. einstalldocs
  51. }