mate-themes-3.16.3.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools gnome2-utils versionator
  5. MATE_GTK_V="$(get_version_component_range 1-2)"
  6. MATE_GTK_NV="3.$(( ${MATE_GTK_V#3.} + 1 ))" #variable to allow negation of =$P-1*
  7. if [[ ${PV#${MATE_GTK_V}.} == 9999 ]]; then
  8. inherit git-r3
  9. EGIT_REPO_URI="https://github.com/mate-desktop/${PN}.git"
  10. EGIT_BRANCH="gtk${MATE_GTK_V}"
  11. else
  12. SRC_URI="http://pub.mate-desktop.org/releases/themes/${MATE_GTK_V}/${P}.tar.xz"
  13. KEYWORDS="amd64 ~arm x86"
  14. fi
  15. HOMEPAGE="http://mate-desktop.org"
  16. DESCRIPTION="A set of MATE themes, with sets for users with limited or low vision"
  17. LICENSE="LGPL-2.1"
  18. SLOT="0/${MATE_GTK_V}"
  19. RDEPEND="
  20. >=x11-libs/gdk-pixbuf-2:2
  21. >=x11-libs/gtk+-2:2
  22. !<x11-libs/gtk+-${MATE_GTK_V}:3
  23. !>=x11-libs/gtk+-${MATE_GTK_NV}:3
  24. >=x11-themes/gtk-engines-2.15.3:2
  25. x11-themes/gtk-engines-murrine"
  26. DEPEND="${RDEPEND}
  27. >=dev-util/intltool-0.35:*
  28. sys-devel/gettext:*
  29. >=sys-devel/autoconf-2.53:*
  30. >=x11-misc/icon-naming-utils-0.8.7:0
  31. virtual/pkgconfig:*"
  32. RESTRICT="binchecks strip"
  33. src_prepare() {
  34. default
  35. eautoreconf
  36. }
  37. pkg_preinst() {
  38. gnome2_icon_savelist
  39. }
  40. pkg_postinst() {
  41. gnome2_icon_cache_update
  42. }
  43. pkg_postrm() {
  44. gnome2_icon_cache_update
  45. }