vdrgraphtft-deeppurple-0.3.2.ebuild 797 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2009 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. inherit eutils
  5. MY_PN="${PN/vdrgraphtft-deeppurple/DeepPurple}"
  6. DESCRIPTION="GraphTFT theme: Alien vs Predator"
  7. HOMEPAGE="http://www.vdr-wiki.de/wiki/index.php/Graphtft-plugin"
  8. SRC_URI="http://vdr.websitec.de/download/${PN}/${MY_PN}.0.3.2.tar.bz2"
  9. KEYWORDS="~x86 ~amd64"
  10. SLOT="0"
  11. LICENSE="GPL-2 LGPL-2.1"
  12. IUSE=""
  13. DEPEND=""
  14. RDEPEND="${DEPEND}
  15. >=media-plugins/vdr-graphtft-0.3.1"
  16. S="${WORKDIR}/DeepPurple"
  17. src_prepare() {
  18. # remove dead links
  19. cd "${S}"/columnimages
  20. rm {srew.png,pause.png,frew1.png,frew2.png,frew3.png,play.png,ffwd1.png,ffwd2.png,ffwd3.png,sfwd.png,recOn.png}
  21. }
  22. src_install() {
  23. insinto /usr/share/vdr/graphTFT/themes/DeepPurple/
  24. doins -r "${S}"/*
  25. }