wm-icons-0.4.0_pre1-r1.ebuild 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit autotools
  4. DESCRIPTION="A Large Assortment of Beutiful Themed Icons, Created with FVWM in mind"
  5. HOMEPAGE="http://wm-icons.sourceforge.net/"
  6. SRC_URI="mirror://gentoo/wm-icons-${PV}-cvs-01092003.tar.bz2"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 ia64 ppc ppc64 x86"
  10. IUSE=""
  11. RDEPEND="virtual/awk dev-lang/perl"
  12. S=${WORKDIR}/wm-icons
  13. src_unpack() {
  14. unpack ${A}
  15. sed -i 's#$(bindir)/wm-icons-config#true#g' "${S}"/Makefile.am
  16. # duplication of bin/Makefile in configure.in #91764
  17. sed -i '132s/bin\/Makefile//' "${S}"/configure.in
  18. # non-portable comment bombs automake.
  19. sed -i 's/\t#/#/' "${S}"/Makefile.am
  20. cd "${S}"
  21. eautoreconf
  22. }
  23. src_compile() {
  24. econf --enable-all-sets --enable-icondir=/usr/share/icons/wm-icons || die "econf failed"
  25. emake || die "emake failed"
  26. }
  27. src_install() {
  28. # strange makefile...
  29. einstall icondir="${D}/usr/share/icons/wm-icons" DESTDIR="${D}" || die
  30. dodir /usr/bin
  31. mv "${D}"/"${D}"/usr/bin/wm-icons-config "${D}"/usr/bin/wm-icons-config
  32. rm -rf "${D}"/var
  33. einfo "Setting default aliases..."
  34. "${D}"/usr/bin/wm-icons-config --user-dir="${D}/usr/share/icons/wm-icons" --defaults
  35. dodoc AUTHORS ChangeLog NEWS README
  36. }
  37. pkg_postinst() {
  38. einfo "Users can use the wm-icons-config utility to create aliases in their"
  39. einfo "home directory, FVWM users can then set this in their ImagePath"
  40. einfo
  41. einfo "Sample configurations for fvwm1, fvwm2, fvwm95 and scwm are available in"
  42. einfo "/usr/share/wm-icons"
  43. einfo
  44. }