zuki-themes-3.20.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MY_PV="${PV}-1"
  5. DESCRIPTION="Zuki themes for GTK, gnome-shell and more"
  6. HOMEPAGE="http://gnome-look.org/content/show.php/Zukitwo?content=140562"
  7. SRC_URI="https://github.com/lassekongo83/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="gnome-shell mate xfce"
  12. RDEPEND="
  13. >=x11-themes/gnome-themes-standard-3.6
  14. >=x11-themes/gtk-engines-murrine-0.98.1.1
  15. gnome-shell? ( media-fonts/roboto )
  16. !<x11-themes/zukitwo-2016.08.08
  17. !<x11-themes/zukitwo-shell-2016.08.08
  18. "
  19. DEPEND=""
  20. S="${WORKDIR}/${PN}-${MY_PV}"
  21. src_configure() { :; }
  22. src_compile() { :; }
  23. src_install() {
  24. insinto /usr/share/themes/Zukitre
  25. doins -r Zukitre/{index.theme,gtk-2.0,gtk-3.0}
  26. use xfce && doins -r Zukitre/xfwm4
  27. insinto /usr/share/themes/Zukitwo
  28. doins -r Zukitwo/{index.theme,gtk-2.0,gtk-3.0}
  29. use mate && doins -r Zukitwo/metacity-1
  30. use xfce && doins -r Zukitwo/xfwm4
  31. if use gnome-shell ; then
  32. insinto /usr/share/themes
  33. doins -r Zuki-shell
  34. fi
  35. default
  36. }