thunar-vcs-plugin-0.1.4.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xfconf
  5. DESCRIPTION="adds Subversion and GIT actions to the context menu of thunar"
  6. HOMEPAGE="http://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin"
  7. SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2
  8. https://dev.gentoo.org/~ssuominen/${P}-el.po.bz2
  9. https://dev.gentoo.org/~ssuominen/${P}-eu.po.bz2
  10. mirror://gentoo/${P}-ru.po.bz2
  11. https://dev.gentoo.org/~ssuominen/${P}-ug.po.bz2
  12. https://dev.gentoo.org/~ssuominen/${P}-uk.po.bz2"
  13. LICENSE="GPL-2"
  14. SLOT="0"
  15. KEYWORDS="amd64 x86"
  16. IUSE="debug +git +subversion"
  17. RDEPEND=">=dev-libs/glib-2.18
  18. >=x11-libs/gtk+-2.14:2
  19. >=xfce-base/exo-0.6
  20. >=xfce-base/libxfce4util-4.8
  21. >=xfce-base/thunar-1.2
  22. git? ( dev-vcs/git )
  23. subversion? (
  24. >=dev-libs/apr-0.9.7
  25. >=dev-vcs/subversion-1.5
  26. )"
  27. DEPEND="${RDEPEND}
  28. dev-util/intltool
  29. virtual/pkgconfig"
  30. pkg_setup() {
  31. XFCONF=(
  32. $(use_enable subversion)
  33. $(use_enable git)
  34. $(xfconf_use_debug)
  35. )
  36. DOCS=( AUTHORS ChangeLog NEWS README )
  37. }
  38. src_prepare() {
  39. # This won't be required for next release anymore, thanks to the following commit:
  40. # http://git.xfce.org/thunar-plugins/thunar-vcs-plugin/commit/?id=e87584f7b87627a322f6e41025e5e52d65ebb4d8
  41. local lang
  42. for lang in el eu ru ug uk; do
  43. mv "${WORKDIR}"/${P}-${lang}.po po/${lang}.po || die
  44. done
  45. xfconf_src_prepare
  46. }