thunar-vcs-plugin-0.1.5.ebuild 869 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xfconf
  5. DESCRIPTION="Adds Subversion and GIT actions to the context menu of thunar"
  6. HOMEPAGE="http://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin"
  7. SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="debug +git +subversion"
  12. RDEPEND=">=dev-libs/glib-2.18:2=
  13. >=x11-libs/gtk+-2.14:2=
  14. >=xfce-base/exo-0.6:=
  15. >=xfce-base/libxfce4util-4.8:=
  16. >=xfce-base/thunar-1.2:=
  17. git? ( dev-vcs/git )
  18. subversion? (
  19. >=dev-libs/apr-0.9.7:=
  20. >=dev-vcs/subversion-1.5:=
  21. )"
  22. DEPEND="${RDEPEND}
  23. dev-util/intltool
  24. virtual/pkgconfig"
  25. pkg_setup() {
  26. XFCONF=(
  27. $(use_enable subversion)
  28. $(use_enable git)
  29. $(xfconf_use_debug)
  30. )
  31. DOCS=( AUTHORS ChangeLog NEWS README )
  32. }